
CONCEPT-II

CONCEPT-II is a frequency domain method of moment (MoM) code, under development 
at the Institute of Electromagnetic Theory at the Technische Universität Hamburg-Harburg 
(www.tet.tuhh.de).

Overview of demo examples

 The following demonstration examples for CONCEPT-II will be discussed in 
detail ($CONCEPT: home directory of the package): 

1.  Wire loop, directory $CONCEPT/demo/example1-wire-loop

2.  Cylindrical monopole antenna radiating over a finite ground plate, 
directory  $CONCEPT/demo/example2-monopole-on-plate

3. Box with aperture and internal radiator, directory 
$CONCEPT/demo/example3-box-with-aperture

4.  Dielectric sphere in a plane wave field, directory 
$CONCEPT/demo/example4-dielectric-sphere

Important: file names should never contain blanks. 

Shortcuts: Help → Navigation

In order to find out how CONCEPT-II works it is recommended to start with example 1.
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http://www.tet.tu-harburg.de/


General Proceeding

Sequence of steps to be carried out in all examples:

● Start of the CONCEPT-II program →  click on the icon on your desktop →  the last 
completed simulation is automatically loaded

● File → Open Simulation → choose the project directory

● Load the control file. Control files end with .sim, for example example1-wire-
loop.sim. The Simulation tab at the left side of the GUI window is active:

○ A right click on an item of the project tree selects it and opens a pull-down menu.

Note that not all entries have a pull-down menu.

○ Example: A right click on Wires opens a list according to the following figure:

○ Selecting New wire file provides a window where to enter the wire data 
(beginning and end coordinates, radii etc.) 

            

● The project tree includes four main sections: 

1. Setup of the structure (geometry, symmetry, surfaces wires etc.)

2. Setup monitoring (specify field probes, current probes) 

3. Setup printing (use the default entries) 

4. Setup simulation (frequency sampling, type of excitation and solver to be used)

● Carefully enter the necessary data 

● Run the simulation by left clicking on the button with the green circle icon  in the 
top left corner of the GUI

● Once the simulation run (back end) has finished, click the Post processing tab and
choose an appropriate button under the 'Compute Results' section. Hovering the 
mouse over an icon gives information on the type of action and purpose, 
respectively.  
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Discretization, creating surface patch meshes 

● Activate the Cad tools tab at the left side of the CONCEPT-II GUI 

● Click on one of the basic tools  and discretize the corresponding 
surface type. Note that the box tool (first left icon) can also be used to generate 
plates, pyramids etc. 

● After having created a proper mesh and/or wire structure click on the Simulation 
tab → The 'Project View' section appears with the simulation project tree left to the 
display area  

○ Right click on the top item of the simulation project tee →  select Load all files 
from 'CAD' (the corresponding files appear under the Wires and/or Surfaces 
entries of the simulation project tree)

○ Should changes on surface grids be necessary activate the Cad tools tab, then 
right click Geometry from simulation → Load simulation file(s) as 
demonstrated in the following figure:
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Example 1: Wire Loop

$CONCEPT/demo/example1-wire-loop

It is recommended to start from an empty directory and set up the 
simulation according to Fig 1. 
The structure to be investigated is a quadratic wire loop, see the following figure. The side 
length is  a=0.1 m, radii of wires: 1 mm, frequency: 1 MHz, voltage generator: 1 V.

Having loaded the file example1-wire-loop.sim the GUI looks like this (right click on 
loop.wire → Edit wires): 

Four straight wires are forming the loop; the coordinates are contained in the file loop.wire.
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Fig 1: Modifying and entering of wire data



Wire files should be named xxx.wire or wire.xxx. 

Surface files should be named accordingly  xxx.surf or surf.xxx with xxx as an arbitrary 
name without blanks. 

Enter the frequency: right click on Frequencies → Single Frequency → a sub-window 
opens →  enter 1 MHz, see Fig 2 → OK

Setting the generator: right click Excitation →Voltage generator(s)  → Select a wire by 
right click, the mouse pointer is turned into a cross when having picked the wire → enter 
amplitude and phase as illustrated in Fig 3 → OK
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Fig 2: Entering the frequency



   

Clicking on  starts the solver. The equation system is set up; the electric field integral 

equation is turned into a linear system of equations which is then solved by LU 
decomposition. 

Activating the Log data tab and clicking on Concept-II-simulation displays the contents 
of the log file concept.out:

*

* CONCEPT-II, Version 12.0
* (C) Copyright 1984-2014, TUHH, E-18
*
*
The current data file: wire-loop.sim
Wire information
================
Wire attached to the ideal ground -> 0
Beginning of a connected wire -> neg. number of that wire is printed
End of a connected wire -> pos. number of that wire is printed
1 6: Beginning and end are attached to wire(s).
Connection(s) at the beginning: 4
Connection(s) at the end: -2
2 6: Beginning and end are attached to wire(s).
Connection(s) at the beginning: 1
Connection(s) at the end: -3
3 6: Beginning and end are attached to wire(s).
Connection(s) at the beginning: 2
Connection(s) at the end: -4
4 6: Beginning and end are attached to wire(s).
Connection(s) at the beginning: 3
Connection(s) at the end: -1
+++++++++++++++++++++++++++++++++++++++

Frequency of step: 1 0.10000E+01 MHz; 
Total number of wire current amplitudes: 36
Total number of patch current amplitudes: 0
Total number of unknowns: 36
+++++++++++++++++++++++++++++++++++++++
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Fig 3: Placing a voltage generator on a wire



Generator (wire): 1
Generator at the middle of wire 1
Input impedance (Ohm): 0.38559E-09 0.19453E+01
Inner impedance of the wire generator: 0.00000000 0.00000000 
Amp. of the excitation voltage: 0.10000E+01 V
Input power: 5.09463860E-11 Watt
Total input power: 0.50946E-10 Watt

Current distribution on 1. wire in A ( 9 current functions)
------------------------------------------------------------
Real part imag. part magnitude phase (degees) wire coord. (m) 
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.55556E-02
0.10189E-09 -0.51405E+00 0.51405E+00 -0.90000E+02 0.16667E-01
...
0.10189E-09 -0.51405E+00 0.51405E+00 -0.90000E+02 0.83333E-01
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.94444E-01

Current distribution on 2. wire in A ( 9 current functions)
------------------------------------------------------------
Real part imag. part magnitude phase (degees) wire coord. (m) 
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.55556E-02
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.16667E-01
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.27778E-01
0.10189E-09 -0.51406E+00 0.51406E+00 -0.90000E+02 0.38889E-01
...

Validation of the results

 As a << λ  we notice a current distribution with constant amplitude.  

The equivalent circuit of our structure comprises 

1. voltage generator (1V, f= 1MHz)

2. The radiation resistance of the loop 

3. The self inductance of the loop

For the radiation resistance we have (analytical solution):

R rad≈31200( A
λ

2 )
2

=0.385⋅10−9
Ω , with A = 0.1m x 0.1m , λ=300m

This value is a very close to the real part of the input impedance, given by  0.38563E-09 
Ω, see above. The self inductance of the loop can be computed by: 

Lanalytical≈
2μ0 a

π ( ln
a
R

−0.774) .

With a =0.1 m, R = 0.001 m we find: Lanalytical=306,49 nH

For the CONCEPT-II result we have: Lnumerical=
X
ω =

0.19453E+01

2 π106
=309,6nH

EM fields along a path or at points in space

The computed current distribution has automatically been saved onto the hard disk and is 
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available for the computation of electromagnetic fields. We want to compute the H field 
along a spatial path running through the center of the loop. 

Activate the Post processing tab and click on .  A sub-window according Fig 4 opens.

 A line with start and end coordinates including 50 probes has been specified, see Fig 5.  

Clicking on Show path(s) displays both the wire loop and the path in the display area. 

Clicking on OK starts the field computation. After the computation has finished a sub-
window according to  Fig 6 opens. We have data for the H field (default file name h-
path1.asc) and choose  'Max. magn.'.  OK provides the H field curve as a function of 
position as illustrated in ( Fig 7 ). 
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Fig 4: Selecting the H field for computation

Fig 5: Entering the path coordinates and the number of field probes



The peak is indicating the position where the path of probes goes through the loop plane. 

This default curve representation can be modified: Right click the following entry of the 
post processing tree:  , see Fig 8 . There are two alternatives to continue:  
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Fig 6: Choosing the field components to be displayed as a function of location

Fig 7: The H field as a function of position.  Click into the display area → The ASCII data of the 
curve can be copied to a different file (see header of file for the content)  



1. Curve selection → Further field components can be selected to be displayed 

2. Show results → The CONCEPT-II Gnuplot front-end opens.  Already existing data 
can immediately be displayed. Individual changes with respect to curve 
representation, captions, and labeling can easily be carried out. Output formats are 
SVG, PNG and Postscript. Existing curve data can be loaded in addition for 
comparison. 

EM fields in 2D regions 
Activate the Simulation tab for changing the frequency to 1000 MHz (see Fig 9). Right 
click Single frequency → Set frequency → enter the frequency value into the sub-
windows which opens. We have to run the solver again clicking on  .

Once we see the message 'Program finished' in the message box (bottom of the GUI) we 
continue with the post processing by clicking on the Post processing tab.
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Fig 8: The post processing tree provides the possibility to quickly reload already computed results 

Fig 9: Changing the frequency



Example: 2D H field distribution at 1000 MHz

The H field distribution shall be displayed in the plane that intersects the wire loop. This 
plane is parallel to the YZ plane, shifted by half the edge length of the square loop 
(0.05cm). 

Click on .  Select the H field, see Fig 4. Then: Field probes → Field in rectangular 2D
region → YZ plane → Set ‘[X] in %’,  ‘[Z] in %’, y position as shown in figure below →  
Compute P1, P2, P3 → the coordinate of the desired field region are computed. Enter the 
number of meshes between points P1,P2 and P3 and click on Show plane/Create 
surf.eh2d → structure and diagram plane are depicted in the display area for control 
purposes.

In the example a 32x32 grid is generated by the following entries (Fig 10 )  : 

Click on OK.  After the field computation has been finished the following windows appears,
select Field(s) at phases (Fig 11 ) 
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Fig 10: Sub-window for specifying a rectangular 2D region for the computation of EM fields. 
The 2D region is described by a file having the CONCEPT-II surface patch data format 
(surf.eh2d). The result file is stored in HDF5 data format, see 
https://support.hdfgroup.org/HDF5/ for information. 

https://support.hdfgroup.org/HDF5/


Click on OK.  We see the distribution of the magnitude of the H field at phase 0° in the 
chosen rectangular field region. 

Next it is recommended to do some scaling for a meaningful field representation. Note that
there is a large variation in the magnitude of the computed field values. Right click onto the
'Scale widget' (right side of the display area). This gives: 

Selecting Arrows circles...  a window according to Fig. Fig 12 appears for arrow scaling.
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Fig 11: Sixteen phase intervals are recommended for a movie. In the general case it is frequently 
helpful to switch ‘Draw contour for rectangular 2D regions’  active



For an appropriate adjustment of the background colors right click on the 'Scale widget' 
again and choose Color Scale... → a sub-window opens, see Fig 13. 

 Vector scaling and color scaling gives the H field distribution as depicted in Fig 14 .
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Fig 12: Window for arrow scaling. 

The default ‘Length:’ of arrows is set to 1. In our case we assume a logarithmic scaling for
the length of the H field vectors and enhance their default length by a factor of 2. In 
addition it has been decided to draw all arrows in 3D mode to ensure a good visibility.

Fig 13: Scaling of the colors.  Push the slider to the left or put in 
directly 'Maximum value:' 0.02 . All field amplitudes that are larger 
will be drawn in red 



To start an animation the Animate button at the lower end of the post processing section 
has to be pressed. If the movie runs too fast set an appropriate ‘Delay’ (right to the 
animate button. Click on  to load the loop in addition to the field plot.

Wire current distribution at 1 GHz
It is assumed that the frequency is 1000 MHz. 

Post processing tab → click on  → a sub-window for configuring the current 
distribution appears. 

Set the ‘Number of phase intervals’ to 16, which is a good number for showing an 
animation. Click on the OK.  The colors along the wires indicate the distribution of the 
current amplitude. The loop current distribution at 0° is shown. Press Animate for a movie,
enter an integer number under ‘Delay’ (for example 100)  to slow down the animation 
speed. 

• Make the wire lines thicker: Options → Setting for wires in the line mode... 

• Wire numbers: Right click on wire.0 (post processing tree) → Show labels → Set a
check mark on  'Show element numbers' → OK

Click on   (tool bar) → a sub-window opens. Select the wires by right clicks and press 
the OK button → a gnuplot preview window appears, showing the corresponding current 
distributions at the specific phase. 

Click on   (left side of the GUI under ‘Compute Results’) → the sub window ‘Current 
distribution, frequency domain’  opens with additional possibilities for current 
representation.  
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Fig 14: Distribution of the H field in a plane parallel to the y-z plane at 90°.  The colors 
represent the magnitude of the field vectors at this phase. Left click and drag → the structure 
can be turned around in the display are. Rotate the mouse wheel to zoom in or to zoom out. 



Placing of lumped loads
Task: each wire shall be loaded in the center by a resistor of 50 Ω. 

Activate the Simulation tab. Select the wire file by right click loop.wire → Set loads.

 A windows where to set the loads opens.

• Right click on a wire → the load symbol appears (green cylinder), a new load line 
appears in the 'CONCEPT-II Loads' window

◦ Lumped loads can be placed at the center, at the beginning and at the end of a 
wire

◦ Right clicking a top entry ('Position', 'Circuitry identifier',...) enables the global 
setting of a value in the respective column

◦ Right clicking on the load line (Load 1 for example) enables to copy, insert, or 
delete the whole line
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Fig 15: Placing lumped loads on wires



◦ Double clicking on a values → individual values can be changed...

• Right click on 'R in Ohm' → Set global →  the small sub-window named 
'CONCEPT-II Load Value' appears. 50 Ω will written into the whole column, notice 
(Fig 15).

• For voltages to be computed as a function of frequency (simulation project tree, 
section Setup monitoring) right click Voltage probes on loop.wire → Set probes 
→ a sub-window with a list of loaded wires appears. Set the check mark to activate 
a voltage probe.  

The corresponding voltage data will be available for post processing after the back 
end has finished.

Change the frequency to 1 kHz: Frequencies → Single frequency → enter 0.001 and run
the simulation. Notice the output: Log data → CONCEPT-II simulation

Computed loop current: (0.5e-2 -j 0.4...e-7) A.
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